Bug #202

SaastamoinenModel with negative height

Added by Evan Ward over 2 years ago. Updated about 1 month ago.

Status:ClosedStart date:2015-05-13
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Using the SaastamoinenModel with a negative height causes an OutOfRangeException. E.g.

Exception in thread "main" org.apache.commons.math3.exception.OutOfRangeException: -0 out of [0, 5] range

While most ground stations are above sea level it is quite possible to have a ground station that is below sea level or below the ellipsoid. I don't know the details of the model, but I think using sea level values would be acceptable for these cases.

History

#1 Updated by Thomas Neidhart over 2 years ago

Evan Ward wrote:

Using the SaastamoinenModel with a negative height causes an OutOfRangeException. E.g.

Exception in thread "main" org.apache.commons.math3.exception.OutOfRangeException: -0 out of [0, 5] range

While most ground stations are above sea level it is quite possible to have a ground station that is below sea level or below the ellipsoid. I don't know the details of the model, but I think using sea level values would be acceptable for these cases.

the problem is mainly with the correction factors which are calculated from interpolation tables. These tables are only defined in the range [0, 5km] and it is undefined how altitudes outside this range shall be treated. I have seen implementations that just return 0 in case an altitude < 0 is provided for the whole path/signal delay. We should at least document what the allowed range of altitude values is.

#2 Updated by Luc Maisonobe 4 months ago

  • Status changed from New to Resolved

Fixed in git repository (see 9e826c41).

#3 Updated by Luc Maisonobe about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF